This project is read-only.

missing namespace downsample4 ?

Mar 3, 2011 at 4:11 AM
Edited Mar 3, 2011 at 4:12 AM

Hey, this api looks very interesting!

i downloaded the latest copy of xen (2.0, feb 22nd) to check it out.

When i run the batch file, i get two errors:

http://img17.imageshack.us/img17/5476/13337143.jpg

im i doing something wrong? all i did was run the .bat file. should i download an earlier version?

Mar 3, 2011 at 7:24 PM

I had the same trouble. I downloaded from a different machine and it wored ok.

Probably something with the OS?!?! However I did not have time to find what happened.

Anyway of you find the solution please let us know.

 

Mar 3, 2011 at 7:36 PM
Edited Mar 3, 2011 at 7:37 PM

Hmm. That is odd.

I did make a small mistake with the downample4 shader. I discovered a nasty bug with it, and accidentally left in some testing code in the release.

If you open up TextureFilter.cs in Xen.Ex/Filters, go to line 1085 and remove the bit:

static Downsample4 s = new Downsample4();

That isn't supposed to be there - I meant to remove that (it was used to test the bug I'd found).
  Also, if that fails, can you upload the file Shader.fx.cs in the same directory (put it up on pastebin will be fine, etc). The shader may not have compiled correctly.

If removing that line fixes it (no idea how that could possibly work) then I'll update the release.

Thanks.

Mar 4, 2011 at 8:24 AM

Hey there StatusUnknown,

I have the following installed:

- .NET Framework 4.0
- XNA Game Studio 4.0
- Latest DirectX SDK

Perhaps I need to install something else?

Removing Downsample4 line hasn't fixed the above problem.

Its also complaining about Downsample2, Downsample8, Kernel16,Kernel15, Kernel8, Kernel7, Kernel4, Kernel2 in TextureFilter.cs

Billboard.cs: DrawBillboardParticles_GpuTex, DrawBillboardParticlesColour_GpuTex, DrawBillboardParticles_GpuTex_UserOffset, DrawBillboardParticlesColour_GpuTex_UserOffset, DrawBillboardParticles_BillboardCpu, DrawBillboardParticlesColour_BillboardCpu

Billboard3d.cs: DrawBillboardParticles_GpuTex3D, DrawBillboardParticlesColour_GpuTex3D, DrawBillboardParticles_GpuTex3D_UserOffset, DrawBillboardParticlesColour_GpuTex3D_UserOffset

VelocityLines.cs: DrawVelocityParticles_LinesGpuTex, DrawVelocityParticlesColour_LinesGpuTex, DrawVelocityParticles_LinesGpuTex_UserOffset, DrawVelocityParticlesColour_LinesGpuTex_UserOffset, DrawVelocityParticles_LinesCpu, DrawVelocityParticlesColour_LinesCpu

(there's others...)

Mar 4, 2011 at 8:44 AM

Can you tell me the contents of the generated shader files (as above)

Also, do you have a DX10 class video card? Xns 4 rewuires this to build most sharers (-grrr-)

Thanks.

Mar 4, 2011 at 11:24 PM
Edited Mar 4, 2011 at 11:24 PM

I can reproduce the error only on my Windows XP machines. That's because they don't support Directx 10

It works fine on all of my windows 7 machines. 

I think its the DirectX that's causing the fail.

Mar 4, 2011 at 11:58 PM
Edited Mar 4, 2011 at 11:59 PM

Thanks. That makes sense.

I'll look at putting in a check to validate DX10 is supported, and update the download page.

Unfortunately, starting with 4.0, XNA requires either a 'HiDef' or 'Reach' graphics device. Where 'HiDef' means DX10 and 'Reach' means DX9 shader model 2.
Things like instancing require shader model 3, and there are some other limitations with Reach that prevent the shader system from doing it's thing. It's annoying, but there isn't much I can do about it.

Thanks again for testing on multiple machines. I appreciate it.

I'll just note: A xen app will work on XP/SM2, provided it doesn't use SM3. Instancing will obviously not be very fast. :-)

Mar 5, 2011 at 2:36 AM
Edited Mar 5, 2011 at 2:37 AM

Hey statusunknown.

Originally I tried to install the xen toolkit on my laptop running windows 7 pro, but i think it has one of those intel media accelerator video cards (total crap). laptop has visual studio 2005, 2008 and 2010. dot net 4.0 and xna 4.0. anyway, it just didnt seem to work.

I tried installing xen on my home pc (running windows 7, ati hd5870 vid card, amd phenom 965, 8gig ram etc). Works fine! I ran the tutorials and I am really impressed with what you've done! Incredible.  I am terrible with shaders (as per my current game that i am working on - http://www.youtube.com/watch?v=QDa6phTKuwE - which i am now at the point where i have to make it  look nice lol). If I have my own camera class (and the camera is just a global static object within the game, that passes its view and projection matrix to everything), how difficult is it to start using the shaders (lighting/shadow and particles/weather system)? Would I need to use the camera class inside xen? or can I simply create something and pass it my camera matrices?

once again, really nice work man.

Mar 5, 2011 at 6:47 PM
StatusUnknown wrote: A xen app will work on XP/SM2, provided it doesn't use SM3. Instancing will obviously not be very fast. :-)

 

Thanks for looking into this StatusUnknown.

How soon can we expect a version of Xen to be backwards compatible with XP and DX9?

There's still a lot of people using this operating system. 

 

Mar 5, 2011 at 7:21 PM

Sorry but you won't get one. Xna 4 requires DX10 in order to build shader model 3 and to use some other basic features. There is little I could do.

Xen apps will still work on XP and dx9, provided they don't use SM3 - but you will not be able to build an app on it.

Sorry

Mar 6, 2011 at 12:03 AM

tell you what; I'll look at seeing if I can support basic shaders, but I don't guarentee anyhting - and instancing and possibly other features will not work. Or it may not be possible. I don't like this though.

Mar 13, 2011 at 7:32 PM
Edited Mar 13, 2011 at 11:20 PM

Ok. Supporting XP / DX9 isn't going to be feasible. It could be done, but I cannot invest the time, and the sacrifices are too great.

I can get the system to build shaders on WinXP / DX9 hardware - the catch is shader model 3 is not supported (because XNA 4 will not let you create a reference device or build a SM3 class shader on a 'Reach' device - it's support DX10 or don't use SM3, basically).

This is fine, I can just disable building instancing shaders (instancing shaders must be built to SM3). This won't break anything - it'll just be slower.

There is a major catch though: The particle system needs SM3 (for GPU acceleration) and so does the Xbox. So in order to support XP I'd also have to remove Xbox support and force the particle systems to always run on the CPU. I'm not prepared to do this, as it'll be a lot of work - and I'm not happy removing some of xen's biggest features.

Long story short: I'm not prepared to do this. If you are unhappy or angry, direct it as Microsoft. Xen 1,8 fully supported XP and didn't even require a SM3 capable video card, this is entirely a Microsoft decision. XP is ancient, DX9 is ancient. Things have moved on. It's painful, sure, but I can completely understand their decision (and frankly I support it)

 

Basically. If you are running XP / DX9, stick with 1.8. It'll give you more features than Xen 2.0 would give you on Xp / DX9.

Mar 22, 2011 at 3:08 PM
Edited Mar 22, 2011 at 3:09 PM

Hi, I just downloaded xen and i'm getting the same build error (type or namespace DownSample4 could not be found), however i'm on win7 and dxdiag informs me i'm running dx11. I installed the directx sdk (june 2010) and repaired my .net framework 4.0 installation (just in case). However i'm still getting this error. I checked the shader.fx.cs file and it has System.IO.FileNotFoundException, it's available at owen.tarmoll.com/Shader.fx.cs if you want to have a look. Just wondering if you have any suggestions as to how i can fix this. I tried installing on another machine and it didn't work (other machine is also win7 dx11) however i should point out the machines are all imacs with bootcamp just in cast that has any bearing on it. Anyway any help would be much appreciated, thanks.

Mar 22, 2011 at 3:37 PM

Hi.

Sorry to hear it's not working,

My first guess is it may be the C++ 2010 runtime. Can you try installing:
http://www.microsoft.com/downloads/en/details.aspx?FamilyID=a7b7a05e-6de6-4d3a-a423-37bf0912db84

Let me know if that helps, cheers.

Mar 22, 2011 at 3:48 PM

No dice, it was already installed. I repaired it anyway but the same build errors still appear. Thank you for your prompt response btw!

Mar 22, 2011 at 4:05 PM
Edited Mar 22, 2011 at 4:06 PM

Ok.

When I get home I'll check the DX SDK I built that .dll against. I'm pretty sure it's the same as the SDK XNA 4 uses, so it should already have the appropriate .dlls installed.

You could also try building Xen.Graphics.ShaderSystem.Native.dll yourself, the Native project is in the shader system directory within src. Only catch is it must be built as a Release build. If it builds fine, then the project build should work (it gets copied to the right place during build).

Mar 22, 2011 at 8:19 PM

Definitely built with June 2010 SDK. I'm not sure what could be going wrong here...

Mar 27, 2011 at 3:31 PM

I have the same problem and environment as slicedpan. Have someone figured it out yet?

Apr 2, 2011 at 11:06 PM

Sorry to hear that :-/

Are you able to build the native project .dll in Release?

Jun 4, 2011 at 6:53 PM

Solved.

I had the same problem. I installed DirectX SDK, commented out the line StatusUnknown talked aboved, deleted everything in "bin" folder and then rebooted (because of DX SDK install). Only after these steps it would build without errors.

I still get one warning "MSB3245: Could not resolve this reference. Could not locate the assembly "Microsoft.Expression.Prototyping.Runtime, Version=3.5.0.0, [...]"

Now I can build and run xen tutorials fine.

Hope it helps

Jul 14, 2011 at 2:36 AM

Just remember to run the .bat as administrator to ensure it is able to load everything. I deleted everything in the bin folder like Templar X stated. Ran the Build.bat as admin and it worked with no errors.