This project is read-only.

Errors with prebuild

May 2, 2009 at 3:02 PM
Edited May 2, 2009 at 5:07 PM
 I keep getting 74 errors when running the prebuild.

Such as this:

sing directive or an assembly reference?)
  Graphics\Display\VelocityBillboard3D.cs(151,22): error CS1061: 'Xen.Ex.Graphi
cs.Display.DrawVelocityBillboardParticlesColour_GpuTex3D_UserOffset' does not c
ontain a definition for 'ColourTexture' and no extension method 'ColourTexture'
 accepting a first argument of type 'Xen.Ex.Graphics.Display.DrawVelocityBillbo
ardParticlesColour_GpuTex3D_UserOffset' could be found (are you missing a using
 directive or an assembly reference?)
  Graphics\Display\VelocityBillboard3D.cs(152,22): error CS1061: 'Xen.Ex.Graphi
cs.Display.DrawVelocityBillboardParticlesColour_GpuTex3D_UserOffset' does not c
ontain a definition for 'VelocityTexture' and no extension method 'VelocityText
ure' accepting a first argument of type 'Xen.Ex.Graphics.Display.DrawVelocityBi
llboardParticlesColour_GpuTex3D_UserOffset' could be found (are you missing a u
sing directive or an assembly reference?)
  Graphics\Display\VelocityBillboard3D.cs(153,22): error CS1061: 'Xen.Ex.Graphi
cs.Display.DrawVelocityBillboardParticlesColour_GpuTex3D_UserOffset' does not c
ontain a definition for 'UserTexture' and no extension method 'UserTexture' acc
epting a first argument of type 'Xen.Ex.Graphics.Display.DrawVelocityBillboardP
articlesColour_GpuTex3D_UserOffset' could be found (are you missing a using dir
ective or an assembly reference?)
  Graphics\Display\VelocityBillboard3D.cs(154,22): error CS1061: 'Xen.Ex.Graphi
cs.Display.DrawVelocityBillboardParticlesColour_GpuTex3D_UserOffset' does not c
ontain a definition for 'DisplayTexture' and no extension method 'DisplayTextur
e' accepting a first argument of type 'Xen.Ex.Graphics.Display.DrawVelocityBill
boardParticlesColour_GpuTex3D_UserOffset' could be found (are you missing a usi
ng directive or an assembly reference?)
  Graphics\Display\VelocityBillboard3D.cs(164,24): error CS1061: 'Xen.Ex.Graphi
cs.Display.DrawVelocityBillboardParticles_GpuTex3D_UserOffset' does not contain
 a definition for 'PositionTexture' and no extension method 'PositionTexture' a
ccepting a first argument of type 'Xen.Ex.Graphics.Display.DrawVelocityBillboar
dParticles_GpuTex3D_UserOffset' could be found (are you missing a using directi
ve or an assembly reference?)
  Graphics\Display\VelocityBillboard3D.cs(165,24): error CS1061: 'Xen.Ex.Graphi
cs.Display.DrawVelocityBillboardParticles_GpuTex3D_UserOffset' does not contain
 a definition for 'VelocityTexture' and no extension method 'VelocityTexture' a
ccepting a first argument of type 'Xen.Ex.Graphics.Display.DrawVelocityBillboar
dParticles_GpuTex3D_UserOffset' could be found (are you missing a using directi
ve or an assembly reference?)
  Graphics\Display\VelocityBillboard3D.cs(166,24): error CS1061: 'Xen.Ex.Graphi
cs.Display.DrawVelocityBillboardParticles_GpuTex3D_UserOffset' does not contain
 a definition for 'UserTexture' and no extension method 'UserTexture' accepting
 a first argument of type 'Xen.Ex.Graphics.Display.DrawVelocityBillboardParticl
es_GpuTex3D_UserOffset' could be found (are you missing a using directive or an
 assembly reference?)
  Graphics\Display\VelocityBillboard3D.cs(167,24): error CS1061: 'Xen.Ex.Graphi
cs.Display.DrawVelocityBillboardParticles_GpuTex3D_UserOffset' does not contain
 a definition for 'DisplayTexture' and no extension method 'DisplayTexture' acc
epting a first argument of type 'Xen.Ex.Graphics.Display.DrawVelocityBillboardP
articles_GpuTex3D_UserOffset' could be found (are you missing a using directive
 or an assembly reference?)
  Graphics\Display\VelocityLines.cs(96,19): error CS1061: 'Xen.Ex.Graphics.Disp
lay.DrawVelocityParticlesColour_LinesGpuTex' does not contain a definition for
'PositionTexture' and no extension method 'PositionTexture' accepting a first a
rgument of type 'Xen.Ex.Graphics.Display.DrawVelocityParticlesColour_LinesGpuTe
x' could be found (are you missing a using directive or an assembly reference?)
  Graphics\Display\VelocityLines.cs(97,19): error CS1061: 'Xen.Ex.Graphics.Disp
lay.DrawVelocityParticlesColour_LinesGpuTex' does not contain a definition for
'ColourTexture' and no extension method 'ColourTexture' accepting a first argum
ent of type 'Xen.Ex.Graphics.Display.DrawVelocityParticlesColour_LinesGpuTex' c
ould be found (are you missing a using directive or an assembly reference?)
  Graphics\Display\VelocityLines.cs(98,19): error CS1061: 'Xen.Ex.Graphics.Disp
lay.DrawVelocityParticlesColour_LinesGpuTex' does not contain a definition for
'VelocityTexture' and no extension method 'VelocityTexture' accepting a first a
rgument of type 'Xen.Ex.Graphics.Display.DrawVelocityParticlesColour_LinesGpuTe
x' could be found (are you missing a using directive or an assembly reference?)
  Graphics\Display\VelocityLines.cs(106,21): error CS1061: 'Xen.Ex.Graphics.Dis
play.DrawVelocityParticles_LinesGpuTex' does not contain a definition for 'Posi
tionTexture' and no extension method 'PositionTexture' accepting a first argume
nt of type 'Xen.Ex.Graphics.Display.DrawVelocityParticles_LinesGpuTex' could be
 found (are you missing a using directive or an assembly reference?)
  Graphics\Display\VelocityLines.cs(107,21): error CS1061: 'Xen.Ex.Graphics.Dis
play.DrawVelocityParticles_LinesGpuTex' does not contain a definition for 'Velo
cityTexture' and no extension method 'VelocityTexture' accepting a first argume
nt of type 'Xen.Ex.Graphics.Display.DrawVelocityParticles_LinesGpuTex' could be
 found (are you missing a using directive or an assembly reference?)
  Graphics\Display\VelocityLines.cs(118,22): error CS1061: 'Xen.Ex.Graphics.Dis
play.DrawVelocityParticlesColour_LinesGpuTex_UserOffset' does not contain a def
inition for 'PositionTexture' and no extension method 'PositionTexture' accepti
ng a first argument of type 'Xen.Ex.Graphics.Display.DrawVelocityParticlesColou
r_LinesGpuTex_UserOffset' could be found (are you missing a using directive or
an assembly reference?)
  Graphics\Display\VelocityLines.cs(119,22): error CS1061: 'Xen.Ex.Graphics.Dis
play.DrawVelocityParticlesColour_LinesGpuTex_UserOffset' does not contain a def
inition for 'ColourTexture' and no extension method 'ColourTexture' accepting a
 first argument of type 'Xen.Ex.Graphics.Display.DrawVelocityParticlesColour_Li
nesGpuTex_UserOffset' could be found (are you missing a using directive or an a
ssembly reference?)
  Graphics\Display\VelocityLines.cs(120,22): error CS1061: 'Xen.Ex.Graphics.Dis
play.DrawVelocityParticlesColour_LinesGpuTex_UserOffset' does not contain a def
inition for 'VelocityTexture' and no extension method 'VelocityTexture' accepti
ng a first argument of type 'Xen.Ex.Graphics.Display.DrawVelocityParticlesColou
r_LinesGpuTex_UserOffset' could be found (are you missing a using directive or
an assembly reference?)
  Graphics\Display\VelocityLines.cs(128,24): error CS1061: 'Xen.Ex.Graphics.Dis
play.DrawVelocityParticles_LinesGpuTex_UserOffset' does not contain a definitio
n for 'PositionTexture' and no extension method 'PositionTexture' accepting a f
irst argument of type 'Xen.Ex.Graphics.Display.DrawVelocityParticles_LinesGpuTe
x_UserOffset' could be found (are you missing a using directive or an assembly
reference?)
  Graphics\Display\VelocityLines.cs(129,24): error CS1061: 'Xen.Ex.Graphics.Dis
play.DrawVelocityParticles_LinesGpuTex_UserOffset' does not contain a definitio
n for 'VelocityTexture' and no extension method 'VelocityTexture' accepting a f
irst argument of type 'Xen.Ex.Graphics.Display.DrawVelocityParticles_LinesGpuTe
x_UserOffset' could be found (are you missing a using directive or an assembly
reference?)
  Graphics\Display\VelocityBillboard.cs(113,19): error CS1061: 'Xen.Ex.Graphics
.Display.DrawVelocityParticlesColour_GpuTex' does not contain a definition for
'PositionTexture' and no extension method 'PositionTexture' accepting a first a
rgument of type 'Xen.Ex.Graphics.Display.DrawVelocityParticlesColour_GpuTex' co
uld be found (are you missing a using directive or an assembly reference?)
  Graphics\Display\VelocityBillboard.cs(114,19): error CS1061: 'Xen.Ex.Graphics
.Display.DrawVelocityParticlesColour_GpuTex' does not contain a definition for
'ColourTexture' and no extension method 'ColourTexture' accepting a first argum
ent of type 'Xen.Ex.Graphics.Display.DrawVelocityParticlesColour_GpuTex' could
be found (are you missing a using directive or an assembly reference?)
  Graphics\Display\VelocityBillboard.cs(115,19): error CS1061: 'Xen.Ex.Graphics
.Display.DrawVelocityParticlesColour_GpuTex' does not contain a definition for
'VelocityTexture' and no extension method 'VelocityTexture' accepting a first a
rgument of type 'Xen.Ex.Graphics.Display.DrawVelocityParticlesColour_GpuTex' co
uld be found (are you missing a using directive or an assembly reference?)
  Graphics\Display\VelocityBillboard.cs(116,19): error CS1061: 'Xen.Ex.Graphics
.Display.DrawVelocityParticlesColour_GpuTex' does not contain a definition for
'DisplayTexture' and no extension method 'DisplayTexture' accepting a first arg
ument of type 'Xen.Ex.Graphics.Display.DrawVelocityParticlesColour_GpuTex' coul
d be found (are you missing a using directive or an assembly reference?)
  Graphics\Display\VelocityBillboard.cs(124,21): error CS1061: 'Xen.Ex.Graphics
.Display.DrawVelocityParticles_GpuTex' does not contain a definition for 'Posit
ionTexture' and no extension method 'PositionTexture' accepting a first argumen
t of type 'Xen.Ex.Graphics.Display.DrawVelocityParticles_GpuTex' could be found
 (are you missing a using directive or an assembly reference?)
  Graphics\Display\VelocityBillboard.cs(125,21): error CS1061: 'Xen.Ex.Graphics
.Display.DrawVelocityParticles_GpuTex' does not contain a definition for 'Veloc
ityTexture' and no extension method 'VelocityTexture' accepting a first argumen
t of type 'Xen.Ex.Graphics.Display.DrawVelocityParticles_GpuTex' could be found
 (are you missing a using directive or an assembly reference?)
  Graphics\Display\VelocityBillboard.cs(126,21): error CS1061: 'Xen.Ex.Graphics
.Display.DrawVelocityParticles_GpuTex' does not contain a definition for 'Displ
ayTexture' and no extension method 'DisplayTexture' accepting a first argument
of type 'Xen.Ex.Graphics.Display.DrawVelocityParticles_GpuTex' could be found (
are you missing a using directive or an assembly reference?)
  Graphics\Display\VelocityBillboard.cs(137,22): error CS1061: 'Xen.Ex.Graphics
.Display.DrawVelocityParticlesColour_GpuTex_UserOffset' does not contain a defi
nition for 'PositionTexture' and no extension method 'PositionTexture' acceptin
g a first argument of type 'Xen.Ex.Graphics.Display.DrawVelocityParticlesColour
_GpuTex_UserOffset' could be found (are you missing a using directive or an ass
embly reference?)
  Graphics\Display\VelocityBillboard.cs(138,22): error CS1061: 'Xen.Ex.Graphics
.Display.DrawVelocityParticlesColour_GpuTex_UserOffset' does not contain a defi
nition for 'ColourTexture' and no extension method 'ColourTexture' accepting a
first argument of type 'Xen.Ex.Graphics.Display.DrawVelocityParticlesColour_Gpu
Tex_UserOffset' could be found (are you missing a using directive or an assembl
y reference?)
  Graphics\Display\VelocityBillboard.cs(139,22): error CS1061: 'Xen.Ex.Graphics
.Display.DrawVelocityParticlesColour_GpuTex_UserOffset' does not contain a defi
nition for 'VelocityTexture' and no extension method 'VelocityTexture' acceptin
g a first argument of type 'Xen.Ex.Graphics.Display.DrawVelocityParticlesColour
_GpuTex_UserOffset' could be found (are you missing a using directive or an ass
embly reference?)
  Graphics\Display\VelocityBillboard.cs(140,22): error CS1061: 'Xen.Ex.Graphics
.Display.DrawVelocityParticlesColour_GpuTex_UserOffset' does not contain a defi
nition for 'UserTexture' and no extension method 'UserTexture' accepting a firs
t argument of type 'Xen.Ex.Graphics.Display.DrawVelocityParticlesColour_GpuTex_
UserOffset' could be found (are you missing a using directive or an assembly re
ference?)
  Graphics\Display\VelocityBillboard.cs(141,22): error CS1061: 'Xen.Ex.Graphics
.Display.DrawVelocityParticlesColour_GpuTex_UserOffset' does not contain a defi
nition for 'DisplayTexture' and no extension method 'DisplayTexture' accepting
a first argument of type 'Xen.Ex.Graphics.Display.DrawVelocityParticlesColour_G
puTex_UserOffset' could be found (are you missing a using directive or an assem
bly reference?)
  Graphics\Display\VelocityBillboard.cs(149,24): error CS1061: 'Xen.Ex.Graphics
.Display.DrawVelocityParticles_GpuTex_UserOffset' does not contain a definition
 for 'PositionTexture' and no extension method 'PositionTexture' accepting a fi
rst argument of type 'Xen.Ex.Graphics.Display.DrawVelocityParticles_GpuTex_User
Offset' could be found (are you missing a using directive or an assembly refere
nce?)
  Graphics\Display\VelocityBillboard.cs(150,24): error CS1061: 'Xen.Ex.Graphics
.Display.DrawVelocityParticles_GpuTex_UserOffset' does not contain a definition
 for 'VelocityTexture' and no extension method 'VelocityTexture' accepting a fi
rst argument of type 'Xen.Ex.Graphics.Display.DrawVelocityParticles_GpuTex_User
Offset' could be found (are you missing a using directive or an assembly refere
nce?)
  Graphics\Display\VelocityBillboard.cs(151,24): error CS1061: 'Xen.Ex.Graphics
.Display.DrawVelocityParticles_GpuTex_UserOffset' does not contain a definition
 for 'UserTexture' and no extension method 'UserTexture' accepting a first argu
ment of type 'Xen.Ex.Graphics.Display.DrawVelocityParticles_GpuTex_UserOffset'
could be found (are you missing a using directive or an assembly reference?)
  Graphics\Display\VelocityBillboard.cs(152,24): error CS1061: 'Xen.Ex.Graphics
.Display.DrawVelocityParticles_GpuTex_UserOffset' does not contain a definition
 for 'DisplayTexture' and no extension method 'DisplayTexture' accepting a firs
t argument of type 'Xen.Ex.Graphics.Display.DrawVelocityParticles_GpuTex_UserOf
fset' could be found (are you missing a using directive or an assembly referenc
e?)
  Graphics\Display\Billboard.cs(82,19): error CS1061: 'Xen.Ex.Graphics.Display.
DrawBillboardParticlesColour_GpuTex' does not contain a definition for 'Positio
nTexture' and no extension method 'PositionTexture' accepting a first argument
of type 'Xen.Ex.Graphics.Display.DrawBillboardParticlesColour_GpuTex' could be
found (are you missing a using directive or an assembly reference?)
  Graphics\Display\Billboard.cs(83,19): error CS1061: 'Xen.Ex.Graphics.Display.
DrawBillboardParticlesColour_GpuTex' does not contain a definition for 'ColourT
exture' and no extension method 'ColourTexture' accepting a first argument of t
ype 'Xen.Ex.Graphics.Display.DrawBillboardParticlesColour_GpuTex' could be foun
d (are you missing a using directive or an assembly reference?)
  Graphics\Display\Billboard.cs(84,19): error CS1061: 'Xen.Ex.Graphics.Display.
DrawBillboardParticlesColour_GpuTex' does not contain a definition for 'Velocit
yTexture' and no extension method 'VelocityTexture' accepting a first argument
of type 'Xen.Ex.Graphics.Display.DrawBillboardParticlesColour_GpuTex' could be
found (are you missing a using directive or an assembly reference?)
  Graphics\Display\Billboard.cs(85,19): error CS1061: 'Xen.Ex.Graphics.Display.
DrawBillboardParticlesColour_GpuTex' does not contain a definition for 'Display
Texture' and no extension method 'DisplayTexture' accepting a first argument of
 type 'Xen.Ex.Graphics.Display.DrawBillboardParticlesColour_GpuTex' could be fo
und (are you missing a using directive or an assembly reference?)
  Graphics\Display\Billboard.cs(92,21): error CS1061: 'Xen.Ex.Graphics.Display.
DrawBillboardParticles_GpuTex' does not contain a definition for 'PositionTextu
re' and no extension method 'PositionTexture' accepting a first argument of typ
e 'Xen.Ex.Graphics.Display.DrawBillboardParticles_GpuTex' could be found (are y
ou missing a using directive or an assembly reference?)
  Graphics\Display\Billboard.cs(93,21): error CS1061: 'Xen.Ex.Graphics.Display.
DrawBillboardParticles_GpuTex' does not contain a definition for 'VelocityTextu
re' and no extension method 'VelocityTexture' accepting a first argument of typ
e 'Xen.Ex.Graphics.Display.DrawBillboardParticles_GpuTex' could be found (are y
ou missing a using directive or an assembly reference?)
  Graphics\Display\Billboard.cs(94,21): error CS1061: 'Xen.Ex.Graphics.Display.
DrawBillboardParticles_GpuTex' does not contain a definition for 'DisplayTextur
e' and no extension method 'DisplayTexture' accepting a first argument of type
'Xen.Ex.Graphics.Display.DrawBillboardParticles_GpuTex' could be found (are you
 missing a using directive or an assembly reference?)
  Graphics\Display\Billboard.cs(107,22): error CS1061: 'Xen.Ex.Graphics.Display
.DrawBillboardParticlesColour_GpuTex_UserOffset' does not contain a definition
for 'PositionTexture' and no extension method 'PositionTexture' accepting a fir
st argument of type 'Xen.Ex.Graphics.Display.DrawBillboardParticlesColour_GpuTe
x_UserOffset' could be found (are you missing a using directive or an assembly
reference?)
  Graphics\Display\Billboard.cs(108,22): error CS1061: 'Xen.Ex.Graphics.Display
.DrawBillboardParticlesColour_GpuTex_UserOffset' does not contain a definition
for 'ColourTexture' and no extension method 'ColourTexture' accepting a first a
rgument of type 'Xen.Ex.Graphics.Display.DrawBillboardParticlesColour_GpuTex_Us
erOffset' could be found (are you missing a using directive or an assembly refe
rence?)
  Graphics\Display\Billboard.cs(109,22): error CS1061: 'Xen.Ex.Graphics.Display
.DrawBillboardParticlesColour_GpuTex_UserOffset' does not contain a definition
for 'VelocityTexture' and no extension method 'VelocityTexture' accepting a fir
st argument of type 'Xen.Ex.Graphics.Display.DrawBillboardParticlesColour_GpuTe
x_UserOffset' could be found (are you missing a using directive or an assembly
reference?)
  Graphics\Display\Billboard.cs(110,22): error CS1061: 'Xen.Ex.Graphics.Display
.DrawBillboardParticlesColour_GpuTex_UserOffset' does not contain a definition
for 'UserTexture' and no extension method 'UserTexture' accepting a first argum
ent of type 'Xen.Ex.Graphics.Display.DrawBillboardParticlesColour_GpuTex_UserOf
fset' could be found (are you missing a using directive or an assembly referenc
e?)
  Graphics\Display\Billboard.cs(111,22): error CS1061: 'Xen.Ex.Graphics.Display
.DrawBillboardParticlesColour_GpuTex_UserOffset' does not contain a definition
for 'DisplayTexture' and no extension method 'DisplayTexture' accepting a first
 argument of type 'Xen.Ex.Graphics.Display.DrawBillboardParticlesColour_GpuTex_
UserOffset' could be found (are you missing a using directive or an assembly re
ference?)
  Graphics\Display\Billboard.cs(118,24): error CS1061: 'Xen.Ex.Graphics.Display
.DrawBillboardParticles_GpuTex_UserOffset' does not contain a definition for 'P
ositionTexture' and no extension method 'PositionTexture' accepting a first arg
ument of type 'Xen.Ex.Graphics.Display.DrawBillboardParticles_GpuTex_UserOffset
' could be found (are you missing a using directive or an assembly reference?)
  Graphics\Display\Billboard.cs(119,24): error CS1061: 'Xen.Ex.Graphics.Display
.DrawBillboardParticles_GpuTex_UserOffset' does not contain a definition for 'V
elocityTexture' and no extension method 'VelocityTexture' accepting a first arg
ument of type 'Xen.Ex.Graphics.Display.DrawBillboardParticles_GpuTex_UserOffset
' could be found (are you missing a using directive or an assembly reference?)
  Graphics\Display\Billboard.cs(120,24): error CS1061: 'Xen.Ex.Graphics.Display
.DrawBillboardParticles_GpuTex_UserOffset' does not contain a definition for 'U
serTexture' and no extension method 'UserTexture' accepting a first argument of
 type 'Xen.Ex.Graphics.Display.DrawBillboardParticles_GpuTex_UserOffset' could
be found (are you missing a using directive or an assembly reference?)
  Graphics\Display\Billboard.cs(121,24): error CS1061: 'Xen.Ex.Graphics.Display
.DrawBillboardParticles_GpuTex_UserOffset' does not contain a definition for 'D
isplayTexture' and no extension method 'DisplayTexture' accepting a first argum
ent of type 'Xen.Ex.Graphics.Display.DrawBillboardParticles_GpuTex_UserOffset'
could be found (are you missing a using directive or an assembly reference?)

    0 Warning(s)
    74 Error(s)

Time Elapsed 00:00:32.76

-----------------------------------
-----------------------------------
- If part of the prebuild failed,
- Check the following are installed:
-
- .NET Framework 3.5
- XNA Game Studio 3.0
- DirectX SDK
-----------------------------------
-----------------------------------

-----------------------------------
- To get started, open:
- ./xen/Tutorials.sln
-----------------------------------

Press any key to continue . . .


 It appears that I have the same error as this guy: http://xen.codeplex.com/Thread/View.aspx?ThreadId=50406
 But there doesn't seem to be a solution yet. I have Windows 32 bit, newest service pack, XNA 2.0 and 3.0 installed, .Net framework 3.5
and directX SDK March 09.

 Any help?






^^ Nevermind to that, I fixed it.. sort of. I compiled the dlls on another comp, and am using them on this one now. (For reference, the comp I compiled them on was Window Vista, 32 bit edition.)
May 3, 2009 at 6:32 AM
Edited May 3, 2009 at 6:37 AM
I've had this error reported twice before. I haven't ever been able to reproduce it unfortunately, I also have little idea what is causing it.
My only guess is it's compiling a shader that uses vertex texture lookup, and failing to create a reference d3d device - and then trying to use shader model 2 hardware device to process the shaders, causing errors. (If your system supports VTF, then I guess this theory if false)

I am in the process of updating the shader processor (and will include the full source in the next release). In theory it will detect the theoretical cause. However it's slow going, as I'm in the process of getting a new job, which is looking very likely to involve moving overseas - plus I've had the flu :-(